Web Automation Error Http 429

Hi, I am trying to log into a website and download data. For some reason on Chrome after I input my credentials and login it goes to an error screen that says “ERROR HTTP 429”. After doing some research I have discovered this means “too many requests”. The issue only happens when using work fusion (not regularly trying to login) and it doesn’t happen on firefox but there are other limitations with firefox so I would prefer to find a solution for this error in Chrome.

Anyone experience this or have a solution for ERROR HTTP 429 in Chrome?

Carolyn h

Hi @cbuchanan can you share the website you log into and your code?

Hi @ashapkina,

please check your inbox as there may be things I can’t post on the forum for this problem right now.


@cbuchanan try adding Wait actions to script when logging in.

@cbuchanan have you tried adding the Wait intervals in the script?

I tried that - 10000ms before and after each step when logging in and nothing worked.

If I launch the website and manually type email, password and click enter there seems to be no issues. But obviously that is a temporary work around not a long term solution.

Do you think longer waits would help? Any other suggestions?

@cbuchanan one more thing: try increasing the polling interval for the actions in the Preferences. By default, it is 300ms.

How long would you recommend? I tried 1000ms but that didn’t change anything :frowning:

@cbuchanan if 1000 hasn’t worked, I’m not sure a bigger timeout will do the trick.

I’m not sure it will work, but try logging in without using web actions, for example, by clicking on images and typing the username/password using Enter Keystrokes action (only for the logging in part). Perhaps, it will work.