Win+r does not work in RPA Express 2.0 on a remote server

keystrokes
#1

I just installed the new version of Workfusion Express 2.0 and I tested some of the bots that I had programmed and that worked correctly in the previous version.

The functionality that does not work is the one that opens the Run dialog to be able to launch a program on the remote server that I have accessed through remote desktop … with the combination of keys (Win + r)

Has anyone had the same or know what could be the cause? … Can someone tell me how to perform the same action with this version of Workfusion RPS Express 2.0?

Thanks in advance

#2

Hi Salvador, does it show any error or does it just skip the Win + r step?

#3

Hello Ashapkina,

It does not show any error, it simply omits the step which means that the inclusion of some order in the “Run” dialog does not take place.

I have also seen that the file paths, when using the keyboard instruction with a text entered, do not spell it correctly, it eliminates some characters such as the backslash, the colon and some other signs (eg the path "E:\Dierector1\Directory2 "introduces it as “EDierectorio1Directorio2”)

Thanks for your deference …

Regards,
Salvador Rovira

#4

Hello again,

Sorry, but the translator has done wrong this translation of the previous post that should be like this: ‘the route “E:\Directorio1\Directorio2” introduces it as “EDirectorio1Directorio2”)’

Thank you…

Regards,
Salvador Rovira

#5

Thank you. We’ll try to reproduce this issue with the team.

#6

Thanks for everything, Alesia, I am waiting for a possible response.

#7

Hi Team,

I am also trying to use win+r in 2.0 version. but its not working. robot skip the step of win+r.

If my win+r already open robot runs next all steps.

Please give me solution for win+r. In most of project we use win+r.

#8

@amol_sonavane @sroviraGPzSDxY this is the result of one of know issues in 2.0 (unstable playback of enter keystrokes) https://kb.workfusion.com/display/RPAe/RPA+Express+2.0.0
We are working on it, expecting to fix it within a couple of weeks.

#9

Hi Alesia,

Thanks for the attention, I hope there is a solution soon because in the opposite case it would be necessary to extend the trial period in order to evaluate the product correctly.

I guess the solution will be implemented in a next update, we will be attentive to new developments in this regard.

Regards,
Salvador Rovira

1 Like
#10

The following observation is noted while Win + r keystroke is pressed. Please share the workaround for this behavior to open the Run window in 2.0.

RPA Express 1.4
image

RPA Express 2.0
image

#11

@anandhan @sroviraGPzSDxY @amol_sonavane this issue has been fixed in version 2.0.1. You can download it using the same link that you received when registered.

#12

Hi,

Win + r issue was fixed in the release 2.0.1, however, the same Win + r combination is not working in the RDP machine. The same worked in 1.4 release. Please find the scenario.

  • Local machine has executed the command Win + r - working
  • Taken remote desktop - working
  • Win + r combination is pressed in the remote machine to open some application - not working
#13

@ashapkina is there any update on the above query?

#14

Hi @anandhan,

Yes, we have been testing this issue, and win+r seems to work, although it can fail in case the remote machine doesn’t have enough time to load before entering win+r.

Try adding a timeout before win+r. Let me know if it helps fix the issue.

#15

Hi @ashapkina,

No luck, it’s not working after giving enough time

#16

does the bot just skip this step?

#17

Hi @ashapkina,

Bot executed that step and shows the status in green color, but the functionality was not worked

#18

@anandhan try changing the Win+r to this sequence:

  • press Win
  • type Run
  • press Enter
#19

@ashapkina

It’s working, but still, this step is not a feasible solution since a single step of execution was split into 3 steps.

This change has to be reflected in all the existing developed projects.

1 Like
#20

@anandhan I agree. The keystrokes are entered faster, and are not always registered because of this. We’ll see how to fix it for future releases.
Thank you for taking your time to test it.