Win+r does not work in RPA Express 2.0 on a remote server

Hi,

Win + r issue was fixed in the release 2.0.1, however, the same Win + r combination is not working in the RDP machine. The same worked in 1.4 release. Please find the scenario.

  • Local machine has executed the command Win + r - working
  • Taken remote desktop - working
  • Win + r combination is pressed in the remote machine to open some application - not working

@ashapkina is there any update on the above query?

Hi @anandhan,

Yes, we have been testing this issue, and win+r seems to work, although it can fail in case the remote machine doesn’t have enough time to load before entering win+r.

Try adding a timeout before win+r. Let me know if it helps fix the issue.

Hi @ashapkina,

No luck, it’s not working after giving enough time

does the bot just skip this step?

Hi @ashapkina,

Bot executed that step and shows the status in green color, but the functionality was not worked

@anandhan try changing the Win+r to this sequence:

  • press Win
  • type Run
  • press Enter

@ashapkina

It’s working, but still, this step is not a feasible solution since a single step of execution was split into 3 steps.

This change has to be reflected in all the existing developed projects.

1 Like

@anandhan I agree. The keystrokes are entered faster, and are not always registered because of this. We’ll see how to fix it for future releases.
Thank you for taking your time to test it.

@ashapkina

Thank you. Did WorkFusion release any RPA Express version other than 2.0.1? If so, how do I get notified about the latest version release?

No, we did not yet.
I’ll post notification on the forum, and we’ll send an email when a new version is available.

@anandhan Could you provide info about your system for testing purposes: your OS, RAM, processor info.
Thank you.

@ashapkina

RAM: 8 GB
Processor: Intel® Xeon® CPU E5-2690 0 @ 2.90GHz 2.90 GHz
OS: Windows Server 2012 Standard

@anandhan Thank you

@ashapkina I worked with the command sequence in RPA Express 2.0.4. But it is not working. Can you tell me in which version this has been fixed because I guess I have the latest version?

I’m on 2.0.1, and I’m still seeing the issue where Win+R is not working unattended. If I’m logged in via Remote Desktop Connection, it works fine. But when I’m logged out and Scheduler is running the process, the process seems to think the action happened because it continues to the next step. However, the target application of the Win+R command is not opened.

@sroviraGPzSDxY @anandhan @amol_sonavane @sbeauchem

This issues should have been fixed with improvements in version 2.1.0.

If you still have this problem, please let me know.

Hi Ashapkina - I recently faced this same issue, and since I downloaded RPA Express last week, I believe I have the version mentioned above. Are you hearing this issue still happening from other users? The robot simply skips this step (win+r).

Thanks! Migs

Hi @lopez.mj if you downloaded it last week, it has to be version 2.3.1.

Do you have a Window action before Win+R?

If you don’t you need to enable the following option in the Preferences to type and use key combinations without the need to switch to the window

image

Otherwise, you need to always switch to the window in which you perform the action to make sure it doesn’t fail.

@ashapkina Thanks! I simply needed to update my preferences as you detailed above.

1 Like