Windows security pin while accessing Web URL

open-website

#1

Hi Team,

I am trying to access an URL, as I say openIE( url), before loading, PIN is being asked (windows Security Desktop pop)

how to overcome that?

Unless the PIN is passed the openIE action is not complete and I am unable to find any option to pass the PIN along with openIE. Kindly help.

Regards,


#2

Hi Shrikant,

Do you open the url in the recorder, using Open website action?


#3

Hi,

I open using recorder.

Regards,


#4

Did you try typing in the password using Enter keystrokes action?


#5

Hi,

when I say open web and pass URL, recorder stays on the same step till the Pages is loaded fully and unless we pass the pin the page will not load fully. sharing Screen shot.


Regards,


#6

If you see above, unless I enter PIN step 2 is not complete, here I don’t see any scope to enter keystrokes.

Regards,


#7

Have you tried just entering keystrokes like this?

or switching to the window, entering keystrokes, and then switching to the browser?

Perhaps, this approach might work, too. If the action Open website fails, the bot switches to the Windows Security window and enters the PIN, and then tries to open the website again.

Let me now if any of these works.


#8

Yes, I have tried this, I get timeout exception at step one, and flow don’t go to second step which is entering keystrokes.

Regards,


#9

Have you tried using Exception handling as shown on the 3rd pic?


#10

Hi thanks,

I got resolved, using image based click at a previous step.

Regards,
Shrikant.


#11

Thank you for letting know @spanada