Workfusion 2.0.1 - Removes spaces in string on RDC

Workfusion - 2.0.1

While automating over remote desktop connection using image based automation, spaces are automatically removed in the string. For example:

’Cisco AnyConnect Secure Mobility Client’ turns to - 'CiscoAnyConnectSecureMobilityClient’

This occurs using following actions:

  • ‘Enter keystrokes’
  • Using clipboard
    (Both while automating the steps while automating on remote desktop connection.)
    This issue has never happened in the earlier versions. Is it system specific or other developers on 2.0.1 are facing the same?
    Please share your thoughts, any help would be appreciated.

Hi @spectator

I think there’s some mistake in your post - both strings look the same.

Could you also provide more details: in which actions are spaced removed? Do you type the text, and the spaces are not typed? Or do you read the text using OCR and there are no spaces in the result?

@ashapkina - Made the required edits, tell me if you need more details/information.

Could you also post your recording of the screenshot of the action flow - we’ll try to reproduce the issue.

I have the same problem. Not only spaces are removed, but so are underscores, slashes and numbers (that I can confirm so far).

This is the text I am sending to the RDC: \babel\Public\IT-Personel\Poh\Ethnocard_11\backup from IOH 2018

This is the text that I see written: babelPublicITPersonelPohEthnocardbackupfromIOH

@rgithkopoulos @spectator where is the text typed: in the browser, in a desktop app or some other location in the remote desktop?

I have tried entering a password to login (failed) and passing a folder path in windows explorer (failed again)…

I can try just opening a notepad in rdc to write some stuff in it, but I am pretty sure it won’t change anything… will try anyway… just published the recording as a bot task to see if I can debug…

thanks for additional info @rgithkopoulos . We’ll try to test this use case on our side.

Confirmed the same problem just by sending keystrokes to an open notepad within the Remote Desktop…

@ashapkina : Sorry for the delayed response.
I’d post the action flow but it won’t be of much help for you.
This error occurs in basic action steps eg. ‘Enter Keystrokes’, ‘Using clipboard’.

However I am attaching a snapshot which will help you recreate the issue.

Workfusion is installed on the first system, the bot logs in to the remote system & using image based automation tries to open ‘Cisco AnyConnect Secure Mobility Client’, but ends up opening 'CiscoAnyConnectSecureMobilityClient. (It is not just spaces, but characters also get removed).

Request you to share your thoughts on the same.

@rgithkopoulos : Thanks for your inputs. Just when I thought it’s just me who’s facing the issue! wink

If anyone has any inputs, feel free to discuss, thanks!

1 Like

@rgithkopoulos : Yes, this is not limited to a few applications, but occurs while moving from local to remote connection. This issue never occurred with previous versions, I can confirm.

Thanks a lot @spectator. This will definitely help us to recreate the issue on our side.

1 Like

Actually, this is probably related to the OS… We tried the same scenario on Windows 10 and it workedRDPtest.zip (690.9 KB)

I have uploaded a video with the successful test on Windows 10.

I will update the thread sometime later with the OS of the workstation where the test was failing (i think it was Windows server, will have to confirm though)…

Thanks @rgithkopoulos. Are you talking about the OS of the local computer or the remote one?

It is failing with Windows 7 Enterprise service pack 1. (Local computer)

I succeeds with Windows 10. (Local computer)

Please note for both of the tests above we connected to different Desktops, so it could be related to remote OS instead of local OS.

1 Like

@ashapkina: Information update:
Migrated my workflows to other local machines & connected to the same remote desktop, it works in a few systems & fails in some.

@rgithkopoulos: Thanks for providing the direction to identify the issue. However, I suggest we need to execute the workflows in additional scenarios to land up to a conclusion.

Further, post-exhaustive testing, please find the results below :-

It works fine with following combination:
Local - Windows 10 Pro - 1803 - 17134
Remote - Windows 10 Pro - 1709 - 16299

But fails:
Local - Windows 10 Pro - 1709 - 16299
Remote - Windows 10 Pro - 1803 - 17134

Here is a workaround you might want to test. Copy the text to clipboard on the local machine and on the remote side just automate the paste procedure (right click + paste)… A colleague of mine says he tried this and it worked…

If this is the case, then the problem should be with the sendKeys method that the recorder uses for the send keystrokes action… I will be testing this myself soon…

2 Likes

Hi, do you have any news ?

Not yet, we are investigating the issue right now.