WorkFusion ControlTower Fails to install

installation
control-tower
rpainstaller

#1

Hi all,

tried to install RPA Express for a while now and seem to have narrowed it down to the Control Tower install.
I’m on a win10 machine, can’t disable windows defender but added exclusions for RPAInstaller and msiexec. Any ideas?

MSI (s) (B4:88) [10:24:35:625]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSICC42.tmp, Entrypoint: ExecSecureObjects
MSI (s) (B4:10) [10:24:35:625]: Generating random cookie.
MSI (s) (B4:10) [10:24:35:628]: Created Custom Action Server with PID 11784 (0x2E08).
MSI (s) (B4:8C) [10:24:35:694]: Running as a service.
MSI (s) (B4:2C) [10:24:35:700]: Hello, I’m your 64bit Elevated Non-remapped custom action server.
ExecSecureObjects: Entering ExecSecureObjects in C:\WINDOWS\Installer\MSICC42.tmp, version 3.11.1701.0
ExecSecureObjects: Securing Object: WorkFusionMySQLService Type: ServiceInstall User: ***
ExecSecureObjects: Error 0x80070534: failed to get sid for account: ***
CustomAction ExecSecureObjects_64 returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (B4:94) [10:24:35:763]: Note: 1: 2265 2: 3: -2147287035
MSI (s) (B4:94) [10:24:35:764]: User policy value ‘DisableRollback’ is 0
MSI (s) (B4:94) [10:24:35:764]: Machine policy value ‘DisableRollback’ is 0
Action ended 10:24:35: InstallFinalize. Return value 3.


#2

Hi Johann, please send us your installation logs from C:\Users%username%\AppData\Local\Temp folder.


#3

Hi Ashapkina,

install logs attached. Thanks

Install Logs.zip (2.8 MB)


#4

@JayOle
Hi Johann,

Sorry for delay on this issue. We hadn’t come across such issue before: Error 0x80070534: failed to get sid for account: JohannZielke.
Is JohannZielke a local or domain account?

Please try and install RPA Express using an admin account. Does it manage to install in this case?

Thank you.


#5

Hi Ashapkina,

I’m on a company Azure Domain and unfortunately don’t have Admin access.


#6

Hi,

I am not able to install RPA Express on my x64 Windows 10 machine. I have 8GB of memory.

I have disabled Windows defender and firewall. The installation stops at Processing: WorkFusion RPA Express and then terminates with an error log.

Virus- and firewall is turned off
image

Log
log.txt (26.4 KB)


#7

Alexander, please send us this log C:\Users\ALEXAN~1\AppData\Local\Temp\WorkFusion_RPA_Express_20180322101232_001_WorkFusionControlTower.log.


#8

WorkFusion_RPA_Express_20180322101232_001_WorkFusionControlTower - copy.zip (2.1 MB)

Hi,

Thanks for the feedback. Added as a .zip


#9

Could you provide output for command “set USER”?

Most likely, you need to install RPA Express under another local (not domain) user with administrator rights.


#10

@alexandert @JayOle
You will be able to install the next version of RPA Express without administrator rights. We have fixed this issue for the next release.


#11

Hi again,

Great feedback. I’ll pass on providing “set user” as I created a local account on my machine, this account was able to install RPAExpress without any problems.

My normal account is able to “run as administrator” and confirm UAC prompt so this might be a fix for more people in here.


#12

Edit:
forgot to change user type to admin, working now. Thanks @alexandert
On Windows 10:
Go to Settings
Accounts
Other People
Add someone else to this PC
I don’t have this person’s sign-in information
Add user without Microsoft account
enter username, password; change to admin
Once installed you can delete account again

Tried installing with new account, no joy.
I’ll wait for the new version, Thanks all.