WorkFusion don't start

New WorkFusion RPA Express user. Installed it and when opening program splash screen appears, then it goes away, Windows “Notification”(?) pops up with message “Welcome to WorkFusion”, orange “V” appears at Taskbar and then goes away. After that nothing, checked out from Taskmanager, WorkFusiuon is no even running.

Find from log files this :


APPLICATION FAILED TO START


Description:

The Tomcat connector configured to listen on port 15100 failed to start. The port may already be in use or the connector may be misconfigured.

Action:

Verify the connector’s configuration, identify and stop any process that’s listening on port 15100, or configure this application to listen on another port.

2018-01-21 21:20:34 [sa-executor-2] ERROR o.a.tomcat.jdbc.pool.ConnectionPool - Unable to create initial connections of pool.
org.postgresql.util.PSQLException: FATAL: the database system is starting up
at org.postgresql.core.v3.ConnectionFactoryImpl.doAuthentication(ConnectionFactoryImpl.java:443)
at org.postgresql.core.v3.ConnectionFactoryImpl.openConnectionImpl(ConnectionFactoryImpl.java:217)
at org.postgresql.core.ConnectionFactory.openConnection(ConnectionFactory.java:51)
at org.postgresql.jdbc.PgConnection.(PgConnection.java:215)
at org.postgresql.Driver.makeConnection(Driver.java:404)
at org.postgresql.Driver.connect(Driver.java:272)
at org.apache.tomcat.jdbc.pool.PooledConnection.connectUsingDriver(PooledConnection.java:310)
at org.apache.tomcat.jdbc.pool.PooledConnection.connect(PooledConnection.java:203)
at org.apache.tomcat.jdbc.pool.ConnectionPool.createConnection(ConnectionPool.java:735)
at org.apache.tomcat.jdbc.pool.ConnectionPool.borrowConnection(ConnectionPool.java:667)
at org.apache.tomcat.jdbc.pool.ConnectionPool.init(ConnectionPool.java:482)
at org.apache.tomcat.jdbc.pool.ConnectionPool.(ConnectionPool.java:154)
at org.apache.tomcat.jdbc.pool.DataSourceProxy.pCreatePool(DataSourceProxy.java:118)
at org.apache.tomcat.jdbc.pool.DataSourceProxy.createPool(DataSourceProxy.java:107)
at org.apache.tomcat.jdbc.pool.DataSourceProxy.getConnection(DataSourceProxy.java:131)
at org.springframework.jdbc.datasource.DataSourceUtils.doGetConnection(DataSourceUtils.java:111)
at org.springframework.jdbc.datasource.DataSourceUtils.getConnection(DataSourceUtils.java:77)
at org.springframework.jdbc.core.JdbcTemplate.execute(JdbcTemplate.java:394)
at org.springframework.jdbc.core.JdbcTemplate.query(JdbcTemplate.java:474)
at org.springframework.jdbc.core.JdbcTemplate.query(JdbcTemplate.java:484)
at org.springframework.jdbc.core.JdbcTemplate.queryForObject(JdbcTemplate.java:494)
at org.springframework.jdbc.core.JdbcTemplate.queryForMap(JdbcTemplate.java:489)
at com.workfusion.status.check.SqlCheck.runImpl(SqlCheck.java:36)
at com.workfusion.status.check.Check.runWithWatch(Check.java:79)
at com.workfusion.status.check.Check.run(Check.java:73)
at com.workfusion.status.task.CheckTask.runWithConfig(CheckTask.java:79)
at com.workfusion.status.task.CheckTask.run(CheckTask.java:51)
at com.workfusion.status.service.TaskService.lambda$scheduleChecks$198(TaskService.java:87)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

@mikkoVKXBiWReM

Hi Nikko,

Looks like the program cannot start because port 15100 might be busy.
Please check if the port is free.

Alesia

Sorry if this is a stupid question but where can i find it?

@mikkoVKXBiWReM
Please run command netstat -aon | more in Windows Command Prompt and send us a screenshot.

22

Maybe this is what you mean:

02

And there’s more. Sorry, i’am Mac user who is learning also Windows with WorkFusion :slight_smile:

08

@mikkoVKXBiWReM
Mikko, thank you.
Please also send us zipped installation logs ( https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-Installationlogs ) and wf-agent logs located at C:\RPAExpress\RPA\wfagent\logs.

Hi,

Uninstalled RPA because i didn’t find installation logs. After reinstalling, it started working!! I already managed to make my first recording.

Now the problem is that i can’t get Bot manager to start. When clicking start, it says “starting” but after about 20 seconds goes to “not started” state.

Control Tower is running.

Closed RPA and started it again. Now Bot Manager started running :slight_smile:

Everything seems to work now. Now it’s time to start studying RPA. This seems little more complicated than UiPath.

1 Like

:face_with_raised_eyebrow:
Glad you managed to start it, anyways.

Hope you enjoy using RPA Express :grinning:
If you have any other issues or questions - please feel free to post here on the forum.

Dear, help me with some information. I want to install the tool on a virtual machine on a server, but I need to release some IP addresses to install, you could give me what addresses are necessary so that I can inform my infrastructure

Regards

Do you mean you need the IP to connect the wrokstation to the server?

You can see how to get it in this tutorial

In fact, I need to install in an environment without internet access, or if I need to have access to which IP I need to inform my infrastructure.

We will virtualize a server machine to test the tool. We work with sensitive information and we have some rules that prevent this connection from outside. I saw that there is an offline installer, can you tell me the link?