WorkFusion RPA Express doesn't start

Hi

I’m starting with this software.
Please your support with this issue.
After the installation, I’ve started the program from de desk, but only opens a file express.vbs, with this code:

Set WshShell = CreateObject("WScript.Shell")
Set ofso = CreateObject("Scripting.FileSystemObject")
WshShell.CurrentDirectory = oFSO.GetParentFolderName(Wscript.ScriptFullName)
WshShell.RUN "..\..\Applications\Java\bin\java -Dagent.showIntro=true -Dloader.path=lib -Dhttp.nonProxyHosts=""localhost|127.0.0.1"" -Djava.awt.headless=false  -Dagent.desktopType=RPA_EXPRESS -Dfile.encoding=UTF-8 -Xmx500m -jar status-agent.jar --spring.config.location=./settings/", 0

Hi @fmorales try this solution from the troubleshooting guide:
https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-RPAExpressshortcutdoesntstartPopupwindowisshowing

Hello. I used RPA Express in my laptop (company owned) until last Wednesday without any problem. I tried to launch it yesterday and RPA Express didn’t start. I click on the shortcut and nothing happens, no icon in the tray, no error message, nothing. I run RPAExpressInstaller.exe using Modify option to update whatever could be wrong but didn’t work. I’m attaching the Shortcut 's details.


express.vbs file:
Set WshShell = CreateObject(“WScript.Shell”)
Set ofso = CreateObject(“Scripting.FileSystemObject”)
WshShell.CurrentDirectory = oFSO.GetParentFolderName(Wscript.ScriptFullName)
WshShell.RUN “…\Applications\Java\bin\java -Dagent.showIntro=true -Dloader.path=lib -Dhttp.nonProxyHosts=”“localhost|127.0.0.1"” -Djava.awt.headless=false -Dagent.desktopType=RPA_EXPRESS -Dfile.encoding=UTF-8 -Xmx500m -jar status-agent.jar --spring.config.location=./settings/", 0

Log files from yesterday: status-agent.2018-12-05.0.log (545.5 KB)
status-agent.log (16.2 KB)

Thanks in advance for your help.

Hi @tovar_e does it open express.vbs file when you click on the icon or does nothing happen at all?

Hi @ashapkina, nothing happens at all. No window, no message, nothing.

Please share the status-agent-error.log, too.

Thank you

@ashapkina, here is the requested log.
status-agent.log (16.2 KB)
Thanks for your help.

This is status-agent log, but in the same folder C:\RPAExpress\RPA\wfagent\logs you should also have status-agent-error.log. Could you please send it?

HI @ashapkina, here’s the log you are asking for

status-agent-error.log (9.2 KB)

Thank you. We’ll have a look now.

Looks like port 15423, which is required for RPA Express, is busy.

Check if any other process is using it:

  • go to Task Manager - Performance - Open Resource Monitor
    image

  • open Network - Listening ports

  • sort by Port and see if any process is using port 15423, which is required for postgres.

image

If it does you need to end this process to start RPa Express.

@ashapkina, no port 15423 listed.

@tovar_e I forwarded this issue to our support team - they will contact you directly.