Workfusion studio can't open Excel file with pivot tables

Can’t get RPA express 2.2 to open an spreadsheet with pivot tables. same file was opening using older versions of RPA express.!

Hello @ghazaleh_taeb.
How do you try to open spreadsheet: using “Open spreadsheet” action or “Launch application”?

using Open spreadsheet action!
This is the error I get:

Capture|690x373

Could you please send send screenshot once again? Unfortunately cannot see it in your post.
I’ve tried to open spreadsheet with pivot table locally, but cannot reproduced, script was executed successfully.

I Also attached my code which is pretty simple.
I tried this with a simple spreadsheet and it works but as soon as there are pivot tables it fails.
Did you try with pivot tables and also new version of RPA express 2.2 or 2.2.1?

In RPA Express v.2.2, when using the Open Spreadsheet action, the bot is failing, giving a ‘zip bomb file detected’ error. Is there anyway to resolve this issue? Apparently this did not occur in previous versions.

Hello @ghazaleh_taeb
Thank you. Is it possible to sent the example of your Excel file? Also please advise which MS Office and Windows is installed on your PC.
Also please provide log files from folder C:\RPAExpress\RPA\logs. You can zip them into one archive.

Hi @joe.turner. Do you have pivot tables in Excel file?

Hi @valeryia_rabchykava, yes it does have Pivot Tables.

Dear @ghazaleh_taeb and @joe.turner, is it possible to provide example of your file with pivot table that failed in RPA Express?
I tried with sample pivot table, but couldn’t reproduce this exception.
Thank you in advance.

Hi Valeryia,

I sent an email to you with the logs and the Excel file a while back do you have any update?

Thanks,

Hi @ghazaleh_taeb. Unfortunately I didn’t receive anything.
Is it possible to attach file to this thread? Also you can send it to me in private message.

Hello @ghazaleh_taeb. Thank you, I received information that you sent to me.

I investigated it and can say that this is not RPA Express issue, but common issue with Excel file. There are a lot of tools that have the same issue with Excel files.
As for your case, I found that if there are any data in pivot tables (in all pivots in file) then Open spreadsheet works as expected. So you can try to “Refresh” for all pivot tables and then save file.

Also you can read about possible workarounds in other sources, for example:
https://support.mulesoft.com/s/article/Zip-bomb-detected-error-when-writing-to-Excel-file


Hope this information helps!

2 Likes