Xpath not working for certain fields in webpage

Xpath not working for certain fields in webpage

Used Mouse click option giving Xpath of both Root cause and empty space , no response…
Any other alternate way to select the same.

image

Perhaps, you should use a custom Xpath for this field.

Can you share the url of the page or the code of the field?

Hi Asha,

Merry Christmas,

Is this the one you are referring to , code of the field -

1 Like

Hi , please check i have updated the code / screenshot of the page

@karan_singh2a try using one of these xpaths:

  • //textarea[@title=“Root Cause”]
  • //*[contains(@class,“TextArea”)]
  • //*[contains(@name,“RootCause”)]

But check that the Xpaths are unique.

Hi , thank you for your kind help , i have tried all the above mentioned options under Web element and mouse click ( Text and Weblement ) as well but getting error message : NoSuchElementException: no such element: Unable to locate element: {“method”:“xpath”,“selector”:".///text()[contains(normalize-space(.), “/textarea[@title=“Root Cause”]”)]/parent::"}

@karan_singh2a could you share a screenshot of the action?

Hi Please check

I have tried the above options with Web Element and mouse click as well

Under mouse clicked i have used WebElement and Text but no success.

There is one slash missing at the start of the Xpath.

//textarea[@title=“Root Cause”]

I am sorry , tried but got no success :frowning:

Does it show the same error?

Yes same error,

@karan_singh2a just noticed that you have the wrong mode in action. You need to use Xpath, not Text.

Same error , tried as advised… :frowning_face:

Can you share the text of the error?